ChatGPT解决这个技术问题 Extra ChatGPT

Is using if (0) to skip a case in a switch supposed to work?

I have a situation where I would like for two cases in a C++ switch statement to both fall through to a third case. Specifically, the second case would fall through to the third case, and the first case would also fall through to the third case without passing through the second case.

I had a dumb idea, tried it, and it worked! I wrapped the second case in an if (0) { ... }. It looks like this:

#ifdef __cplusplus
#  include <cstdio>
#else
#  include <stdio.h>
#endif

int main(void) {
    for (int i = 0; i < 3; i++) {
        printf("%d: ", i);
        switch (i) {
        case 0:
            putchar('a');
            // @fallthrough@
            if (0) {        // fall past all of case 1 (!)
        case 1:
            putchar('b');
            // @fallthrough@
            }
        case 2:
            putchar('c');
            break;
        }
        putchar('\n');
    }
    return 0;
}

When I run it, I get the desired output:

0: ac
1: bc
2: c

I tried it in both C and C++ (both with clang), and it did the same thing.

My questions are: Is this valid C/C++? Is it supposed to do what it does?

Yes, this is valid and works for pretty much the same reasons why Duff's device does.
Note that code like this will get you tossed out of any code walkthrough in an environment that cares even just a little about readability and maintainability.
This is horrible. Even more horrible than Duff's device, mind you. Related, I also recently saw something like switch(x) { case A: case B: do_this(); if(x == B) also_do_that(); ... }. That was also, IMO, horrible. Please, just write stuff like that out as if statements, even if it means you have to repeat one line in two places. Use functions and variables (and documentation!) to reduce the risk of accidentally later updating in only one place.
:-) For those who were injured or maimed due to looking at that code, I didn't say it was a good idea. In fact, I said it was a dumb idea.
Note that constructions inside switches like this do NOT play well with RAII :(

R
R.. GitHub STOP HELPING ICE

Yes, this is supposed to work. The case labels for a switch statement in C are almost exactly like goto labels (with some caveats about how they work with nested switch statements). In particular, they do not themselves define blocks for the statements you think of as being "inside the case", and you can use them to jump into the middle of a block just like you could with a goto. When jumping into the middle of a block, the same caveats as with goto apply regarding jumping over initialization of variables, etc.

With that said, in practice it's probably clearer to write this with a goto statement, as in:

    switch (i) {
    case 0:
        putchar('a');
        goto case2;
    case 1:
        putchar('b');
        // @fallthrough@
    case2:
    case 2:
        putchar('c');
        break;
    }

"When jumping into the middle of a block, the same caveats as with goto apply regarding jumping over initialization of variables, etc" What caveats would those be? You cannot jump over the initialization of variables.
@AsteroidsWithWings, do you mean "cannot" from a standards-conforming perspective, or from the kind of practical perspective that a compiler will not allow it? Because my GCC does allow it in C mode, with a warning. It doesn't allow it in C++ mode though.
@quetzalcoatl gcc-9 and clang-6 both allow this code, warning about potentially uninitialized bee (in C mode; in C++ they error out on "cannot jump from switch statement to this case label/jump bypasses variable initialization").
You know you’re doing something wrong when using goto is the cleaner solution.
@KonradRudolph: goto is much maligned but there's really nothing objectionable about it if you're not making complex control structures out of it manually. The whole "goto considered harmful" was about writing HLL (e.g. C) code that looks like asm emitted by a compiler (jmps back and forth all over the place). There are lots of good structured uses of goto like forward-only (conceptually no different than break or early return), unlikely-retry-loop-only (avoids obscuring common flow path & compensates for lack of nested-continue), etc.
c
cigien

Yes, this is allowed, and it does what you want. For a switch statement, the C++ standard says:

case and default labels in themselves do not alter the flow of control, which continues unimpeded across such labels. To exit from a switch, see break. [Note 1: Usually, the substatement that is the subject of a switch is compound and case and default labels appear on the top-level statements contained within the (compound) substatement, but this is not required. Declarations can appear in the substatement of a switch statement. — end note]

So when the if statement is evaluated, control flow proceeds according to the rules of an if statement, regardless of intervening case labels.


As a specific case of this, one can look at Boost.Coroutines for a set of stomach-churning macros which take advantage of this rule (and a half dozen other corner cases of C++) to implement coroutines using C++03 rules. They were not made part of the language until C++20, but these macros made them work... as long as you took your antacids first!
P
Pete Becker

As other answers have mentioned, this is technically allowed by the standard, but it is very confusing and unclear to future readers of the code.

This is why switch ... case statements should usually be written with function calls and not lots of inline code.

switch(i) {
case 0:
    do_zero_case(); do_general_stuff(); break;
case 1:
    do_one_case(); do_general_stuff(); break;
case 2:
    do_general_stuff(); break;
default:
    do_default_not_zero_not_one_not_general_stuff(); break;
}

Note that the code in the question doesn't do_general_stuff for default, only for case 2 (and 0 and 1). It never runs the switch for an i outside the 0..2 range, though.
@PeterCordes -- note that the code in the answer doesn't do_general_stuff for default, only for case 2 (and 0 and 1).
A suggestion - maybe the default case should be removed or renamed? It's quite easy to miss the different function names.
@PeteBecker: Oh, IDK how I missed that general and default were different words. OTOH, it's a known fact that humans can usually still read a word if the middle letters are scrambled; we tend to look at the start and end, so having only the middle be different is probably not ideal for skimmability. Perhaps remove the do_ prefix.
@supercat: That "well-known fact" is not about replacing the middle letters by different ones, but just about mixing up the order of then. "If the cialm wree true in graneel, you sluhod be albe to raed tihs."