ChatGPT解决这个技术问题 Extra ChatGPT

Declaring multiple variables in JavaScript

In JavaScript, it is possible to declare multiple variables like this:

var variable1 = "Hello, World!";
var variable2 = "Testing...";
var variable3 = 42;

...or like this:

var variable1 = "Hello, World!",
    variable2 = "Testing...",
    variable3 = 42;

Is one method better/faster than the other?

As for faster, using this jsperf I couldn't see a consistent speed gain using one method or the other.
let one=1,tow=2,three=3;

K
Kate Orlova

The first way is easier to maintain. Each declaration is a single statement on a single line, so you can easily add, remove, and reorder the declarations.

With the second way, it is annoying to remove the first or last declaration because they start from the var keyword and finish with the semicolon respectively. Every time you add a new declaration, you have to replace the semicolon in the last old line with a comma.


If you're writing code that you expect to minify or pack later, the second way allows compressors (like the YUI Compressor) to give you a more minified version. If size is a consideration, then I would suggest following as many of JSLint's suggestions as possible.
jslint claims that second way is more righteous but I disagree.
The second way is a micro-optimization. All the var declarations are processed at once, rather than one at a time. This doesn't matter that much in modern browsers/modern computers.
@0xc0de: I would like to see the proof of declaring all the variables in one statement as "efficient". If you are only measuring efficiency as a matter of the few bytes saved, then maybe. But if you take into account readability and maintainability, I think you'll find that premature optimization is usually the wrong way to go, especially since modern browsers will collect and initialize all the variables in a scope on a pre-execution pass. Personally, I find having variables all declared in a single line or statement to make quickly understanding code harder and more error prone.
Concerning efficiency, both uglifyjs and the google closure compiler will automatically squash sequential var statements into one, rendering that point moot (as far as I can tell YUI will not do this, however I haven't tested extensively).
P
Peter Mortensen

Besides maintainability, the first way eliminates possibility of accident global variables creation:

(function () {
var variable1 = "Hello, World!" // Semicolon is missed out accidentally
var variable2 = "Testing..."; // Still a local variable
var variable3 = 42;
}());

While the second way is less forgiving:

(function () {
var variable1 = "Hello, World!" // Comma is missed out accidentally
    variable2 = "Testing...", // Becomes a global variable
    variable3 = 42; // A global variable as well
}());

Good point. If they're short, then writing on a single line will avoid this problem: var variable1 = "Hello World!", variable2 = "Testing...", variable3 = 42;. A missing , will crash, but I agree it's risky
If you're using strict mode you won't be able to create globals like this anyway.
I'm a fan of declaring multiple variables on a single line because I think it looks cleaner. That said, accidentally declaring global variables is a real danger. While hunting down memory leaks I have come across multiple instances where I accidentally declared several global variables at once because I used a semicolon instead of a comma.
My text editor gives me a Possible Fatal Error if I miss a coma, hurray for me!
J
Jason Stackhouse

It's much more readable when doing it this way:

var hey = 23;
var hi = 3;
var howdy 4;

But takes less space and lines of code this way:

var hey=23,hi=3,howdy=4;

It can be ideal for saving space, but let JavaScript compressors handle it for you.


s
spencer.sm

It's common to use one var statement per scope for organization. The way all "scopes" follow a similar pattern making the code more readable. Additionally, the engine "hoists" them all to the top anyway. So keeping your declarations together mimics what will actually happen more closely.


You can keep the declarations together without making them sharing the same 'var' declaration. I understand and accept the explanations given at jslint (your link) but I don't share the conclusion. As said above, it is more matter of style than anything else. In the Java world (among others), the reverse (one declaration per line) is recommended for readability.
More readable? The only reason people put them on one line is the JS-specific reason you mentioned: JS moves all the declarations to the top. If it didn't do that, we would all be declaring our vars closest to the point where they are used.
G
General Grievance

ECMAScript 2015 introduced destructuring assignment which works pretty nice:

[a, b] = [1, 2]

a will equal 1 and b will equal 2.


it doesn't answer the question, but it can be a better alternative to both described approaches.
I think that your approach is not really viable in case if you have long lists of variables. It is hard to say to which variable which value is related and also you don't have protection from errors is case of bad merge during which you accidentally could remove one element from an array. Example: let [aVar, bVar, cVar, xVar, yVar, zVar] = [10, 20, 30, 40, 50]; So, personally I do not recommend it.
handy if you want to set a lot of variables with the same values though. Using to reset to zero in a loop for instance.
Yes! this is what I was looking for. Especially if you want to define a two dimensional pair, or multi-dimensional values, yet not arrays.
B
Brian Campbell

It's just a matter of personal preference. There is no difference between these two ways, other than a few bytes saved with the second form if you strip out the white space.


The second one saves a couple of bytes.
If you strip out the whitespace, than the 'var foo="hello",bar="world";' declaration takes up fewer characters than 'var foo="hello";var bar="world";' If you have a popular site, saving a few bytes on the JS can help (you'd also want to minimize variable names, etc)
I see this the saved bytes as irrelevant at this time, due to the rise of JavaScript minifiers, notably the Google Closer Compiler's (so-called) simple mode.
This is an incorrect statement - there is a difference in how the runtime engine processes them (at least in older browsers, not sure about modern browsers). I could've sworn I read it in High Performance Javascript by Zakas, but I'm having a hard time locating it right now. I'll keep my eye open and check back with a reference when I've got it. It isn't a major difference anyway - just a performance one from what I recall (and a tiny micro-performance difference at that).
@webnesto there's never any performance from syntax when the semantics of the syntax are the same. One will not execute code right away but first parse it and do semantic analysis - this is where both of the declaration styles are equalized.
P
Peter Mortensen

Maybe like this

var variable1 = "Hello, World!"
, variable2 = 2
, variable3 = "How are you doing?"
, variable4 = 42;

Except when changing the first or last variable, it is easy to maintain and read.


Typically, using comma-first, the semicolon goes on a new line to prevent that issue. var variable1 = "hello world"\n , variable2 = 2\n , variable3 = "how are you doing"\n , variable4 = 42\n ;\n
This is Haskell syntax. I feel that somehow it is not recommended/common practice in javascript
P
Peter Mortensen

Use the ES6 destructuring assignment: It will unpack values from arrays, or properties from objects, into distinct variables.

let [variable1 , variable2, variable3] = ["Hello, World!", "Testing...", 42]; console.log(variable1); // Hello, World! console.log(variable2); // Testing... console.log(variable3); // 42


It is a terrible idea, especially if you need to assign around 10 variables.
P
Peter Mortensen
var variable1 = "Hello, World!";
var variable2 = "Testing...";
var variable3 = 42;

is more readable than:

var variable1 = "Hello, World!",
    variable2 = "Testing...",
    variable3 = 42;

But they do the same thing.


Uses less "file space"? I think you have some explaining to do.
@JoshStodola looks the same file space to me. Since rather than var<space>, its <space><space><space><space>
@WORMSS unless it's var<space> or var<tab> vs <tab>. Still largely moot.
s
shawn

Another reason to avoid the single statement version (single var) is debugging. If an exception is thrown in any of the assignment lines the stack trace shows only the one line.

If you had 10 variables defined with the comma syntax you have no way to directly know which one was the culprit.

The individual statement version does not suffer from this ambiguity.


P
Peter Mortensen

My only, yet essential, use for a comma is in a for loop:

for (var i = 0, n = a.length; i < n; i++) {
  var e = a[i];
  console.log(e);
}

I went here to look up whether this is OK in JavaScript.

Even seeing it work, a question remained whether n is local to the function.

This verifies n is local:

a = [3, 5, 7, 11];
(function l () { for (var i = 0, n = a.length; i < n; i++) {
  var e = a[i];
  console.log(e);
}}) ();
console.log(typeof n == "undefined" ?
  "as expected, n was local" : "oops, n was global");

For a moment I wasn't sure, switching between languages.


P
Peter Mortensen

Although both are valid, using the second discourages inexperienced developers from placing var statements all over the place and causing hoisting issues. If there is only one var per function, at the top of the function, then it is easier to debug the code as a whole. This can mean that the lines where the variables are declared are not as explicit as some may like.

I feel that trade-off is worth it, if it means weaning a developer off of dropping 'var' anywhere they feel like.

People may complain about JSLint, I do as well, but a lot of it is geared not toward fixing issues with the language, but in correcting bad habits of the coders and therefore preventing problems in the code they write. Therefore:

"In languages with block scope, it is usually recommended that variables be declared at the site of first use. But because JavaScript does not have block scope, it is wiser to declare all of a function's variables at the top of the function. It is recommended that a single var statement be used per function." - http://www.jslint.com/lint.html#scope


The link is (effectively) broken - it redirects to a generic page.
P
Peter Mortensen

I think it's a matter of personal preference. I prefer to do it in the following way:

   var /* Variables */
            me = this, that = scope,
            temp, tempUri, tempUrl,
            videoId = getQueryString()["id"],
            host = location.protocol + '//' + location.host,
            baseUrl = "localhost",
            str = "Visit W3Schools",
            n = str.search(/w3schools/i),
            x = 5,
            y = 6,
            z = x + y
   /* End Variables */;

P
Peter Mortensen

The maintainability issue can be pretty easily overcome with a little formatting, like such:

let
  my_var1 = 'foo',
  my_var2 = 'bar',
  my_var3 = 'baz'
;

I use this formatting strictly as a matter of personal preference. I skip this format for single declarations, of course, or where it simply gums up the works.


What is the gist of your formatting? let and the semicolon on lines of their own? Or something else? In what way does it help with the maintainability issue? What is the maintainability issue? (These are not rhetorical questions.) The best response would be editing your answer (without "Edit:", "Update:" or similar), not here in comments.
S
Schalton

As everyone has stated it is largely preference and readability, but I'll throw a comment on the thread since I didn't see others share thoughts in this vein

I think the answer to this question is largely dependent on what variables you're setting and how they're related. I try to be consistent based on if the variables I'm creating are related or not; my preference generally looks something like this:

For unrelated variables

I single-line them so they can be easily moved later; I personally would never declare unrelated items any other way:

const unrelatedVar1 = 1;
const unrelatedVar2 = 2;
const unrelatedVar3 = 3;

For related things (utility)

If I'm creating new variables I declare as a block -- this serves as a hint that the attributes belong together

const
  x = 1,
  y = 2,
  z = 3
;

// or
const x=1, y=2, z=3;

// or if I'm going to pass these params to other functions/methods
const someCoordinate = {
  x = 1,
  y = 2,
  z = 3
};

this, to me, feels more consistent with de-structuring:

const {x,y,z} = someCoordinate;

where it'd feel clunky to do something like (I wouldn't do this)

const x = someCoordiante.x;
const y = someCoordiante.y;
const z = someCoordiante.z;

For related things (construction)

If multiple variables are created with the same constructor I'll often group them together also; I personally find this more readable

Instead of something like (I don't normally do this)

const stooge1 = Person("moe");
const stooge2 = Person("curly");
const stooge3 = Person("larry");

I'll usually do this:

const [stooge1, stooge2, stooge3] = ["moe", "curly", "larry"].map(Person);

I say usually because if the input params are sufficiently long that this becomes unreadable I'll split them out.

I agree with other folk's comments about use-strict


P
Peter Mortensen

The concept of "cohesion over coupling" can be applied more generally than just objects/modules/functions. It can also serve in this situation:

The second example the OP suggested has coupled all the variables into the same statement, which makes it impossible to take one of the lines and move it somewhere else without breaking stuff (high coupling). The first example he gave makes the variable assignments independent of each other (low coupling).

From Coupling:

Low coupling is often a sign of a well-structured computer system and a good design, and when combined with high cohesion, supports the general goals of high readability and maintainability.

So choose the first one.


I fail to see how this is related to coupling or cohesion. Care to elaborate?
The second example the OP suggested has coupled all the variables into the same statement, which makes it impossible to take one of the lines and move it somewhere else without breaking stuff (high coupling). The first example he gave makes the variable assignments independent of each other (low coupling).
Coupling is about interdependency between different modules/objects/functions, NOT lines of code!
Originally it was about modules, yes, but the concept can be applied more generally, as even your own inclusion of objects/functions into the definition shows.
P
Peter Mortensen

I believe that before we started using ES6, an approach with a single var declaration was neither good nor bad (in case if you have linters and 'use strict'. It was really a taste preference. But now things changed for me. These are my thoughts in favour of multiline declaration:

Now we have two new kinds of variables, and var became obsolete. It is good practice to use const everywhere until you really need let. So quite often your code will contain variable declarations with assignment in the middle of the code, and because of block scoping you quite often will move variables between blocks in case of small changes. I think that it is more convenient to do that with multiline declarations. ES6 syntax became more diverse, we got destructors, template strings, arrow functions and optional assignments. When you heavily use all those features with single variable declarations, it hurts readability.


P
Peter Mortensen

I think the first way (multiple variables) is best, as you can otherwise end up with this (from an application that uses KnockoutJS), which is difficult to read in my opinion:

    var categories = ko.observableArray(),
        keywordFilter = ko.observableArray(),
        omniFilter = ko.observable('').extend({ throttle: 300 }),
        filteredCategories = ko.computed(function () {
            var underlyingArray = categories();
            return ko.utils.arrayFilter(underlyingArray, function (n) {
                return n.FilteredSportCount() > 0;
            });
        }),
        favoriteSports = ko.computed(function () {
            var sports = ko.observableArray();
            ko.utils.arrayForEach(categories(), function (c) {
                ko.utils.arrayForEach(c.Sports(), function (a) {
                    if (a.IsFavorite()) {
                        sports.push(a);
                    }
                });
            });
            return sports;
        }),
        toggleFavorite = function (sport, userId) {
            var isFavorite = sport.IsFavorite();

            var url = setfavouritesurl;

            var data = {
                userId: userId,
                sportId: sport.Id(),
                isFavourite: !isFavorite
            };

            var callback = function () {
                sport.IsFavorite(!isFavorite);
            };

            jQuery.support.cors = true;
            jQuery.ajax({
                url: url,
                type: "GET",
                data: data,
                success: callback
            });
        },
        hasfavoriteSports = ko.computed(function () {
            var result = false;
            ko.utils.arrayForEach(categories(), function (c) {
                ko.utils.arrayForEach(c.Sports(), function (a) {
                    if (a.IsFavorite()) {
                        result = true;
                    }
                });
            });
            return result;
        });

A
Ajay Sahu

A person with c background will definitely use the second method

var variable1 = "Hello, World!",
variable2 = "Testing...",
variable3 = 42;

the above method is more look like in c language