ChatGPT解决这个技术问题 Extra ChatGPT

Setting environment variables on OS X

What is the proper way to modify environment variables like PATH in OS X?

I've looked on Google a little bit and found three different files to edit:

/etc/paths

~/.profile

~/.tcshrc

I don't even have some of these files, and I'm pretty sure that .tcshrc is wrong, since OS X uses bash now. Where are these variables, especially PATH, defined?

I'm running OS X v10.5 (Leopard).

env "switch.1.disabled=true" open -n /Applications/Eclipse.app/ to launch GUI application with a new set system environment.
.tcshrc is obviously only useful if you use Tcsh. If you do, welcome to the 21st century! You'll be surprised to hear that there are now Bourne-compatible free open-source shells.

F
Frankenmint

Bruno is right on track. I've done extensive research and if you want to set variables that are available in all GUI applications, your only option is /etc/launchd.conf.

Please note that environment.plist does not work for applications launched via Spotlight. This is documented by Steve Sexton here.

Open a terminal prompt Type sudo vi /etc/launchd.conf (note: this file might not yet exist) Put contents like the following into the file # Set environment variables here so they are available globally to all apps # (and Terminal), including those launched via Spotlight. # # After editing this file run the following command from the terminal to update # environment variables globally without needing to reboot. # NOTE: You will still need to restart the relevant application (including # Terminal) to pick up the changes! # grep -E "^setenv" /etc/launchd.conf | xargs -t -L 1 launchctl # # See http://www.digitaledgesw.com/node/31 # and http://stackoverflow.com/questions/135688/setting-environment-variables-in-os-x/ # # Note that you must hardcode the paths below, don't use environment variables. # You also need to surround multiple values in quotes, see MAVEN_OPTS example below. # setenv JAVA_VERSION 1.6 setenv JAVA_HOME /System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home setenv GROOVY_HOME /Applications/Dev/groovy setenv GRAILS_HOME /Applications/Dev/grails setenv NEXUS_HOME /Applications/Dev/nexus/nexus-webapp setenv JRUBY_HOME /Applications/Dev/jruby setenv ANT_HOME /Applications/Dev/apache-ant setenv ANT_OPTS -Xmx512M setenv MAVEN_OPTS "-Xmx1024M -XX:MaxPermSize=512m" setenv M2_HOME /Applications/Dev/apache-maven setenv JMETER_HOME /Applications/Dev/jakarta-jmeter Save your changes in vi and reboot your Mac. Or use the grep/xargs command which is shown in the code comment above. Prove that your variables are working by opening a Terminal window and typing export and you should see your new variables. These will also be available in IntelliJ IDEA and other GUI applications you launch via Spotlight.


I'm saying that the accepted answer (environment.plist) has not been successful for me. I've successfully used the launchd.conf approach on 10.5 and 10.6 on four machines.
Is there any way of doing this without doing a system reboot?
The limitation mentioned above applies to MacOS X 10.5. However MacOS X 10.6 does not have this limitation anymore and setting the values inside environment.plist works fine even for apps launched via spotlight. So the selected answer is correct for Snow Leopard ;-)
Setting launchd.conf is one way, but needs a reboot (to restart launchd). If you want to avoid a reboot, see my answer stackoverflow.com/questions/135688/…
There are several problems with the presented launchd approach. Most are specific to the PATH environment variable, but the asker did mention PATH specifically. 1) items in launchd.conf do not get applied in interactive shells such as ssh into the system. 2) having the line "setenv PATH /testdir" appends to the PATH in Terminal.app, but blows away all other PATH items in OS X Applications' Environments. 3)Doing "setenv PATH ${PATH}:/testdir" in /etc/launchd.conf doesn't properly expand existing $PATH 4)launchd.conf applies to all users, instead of just one. Not that I have any better soln.
M
Matt Curtis

Don't expect ~/.launchd.conf to work

The man page for launchctl says that it never worked:

DEPRECATED AND REMOVED FUNCTIONALITY launchctl no longer has an interactive mode, nor does it accept commands from stdin. The /etc/launchd.conf file is no longer consulted for subcommands to run during early boot time; this functionality was removed for security considerations. While it was documented that $HOME/.launchd.conf would be consulted prior to setting up a user's session, this functionality was never implemented.

How to set the environment for new processes started by Spotlight (without needing to reboot)

You can set the environment used by launchd (and, by extension, anything started from Spotlight) with launchctl setenv. For example to set the path:

launchctl setenv PATH /opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin

Or if you want to set up your path in .bashrc or similar, then have it mirrored in launchd:

PATH=/opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin
launchctl setenv PATH $PATH

There's no need to reboot though you will need to restart an app if you want it to pick up the changed environment.

This includes any shells already running under Terminal.app, although if you're there you can set the environment more directly, e.g. with export PATH=/opt/local/bin:/opt/local/sbin:$PATH for bash or zsh.

How to keeping changes after a reboot

New method (since 10.10 Yosemite)

Use launchctl config user path /bin:/usr/bin:/mystuff. See man launchctl for more information.

Previous method

The launchctl man page quote at the top of this answer says the feature described here (reading /etc/launchd.conf at boot) was removed for security reasons, so ymmv.

To keep changes after a reboot you can set the environment variables from /etc/launchd.conf, like so:

setenv PATH /opt/local/bin:/opt/local/sbin:/usr/bin:/bin:/usr/sbin:/sbin

launchd.conf is executed automatically when you reboot.

If you want these changes to take effect now, you should use this command to reprocess launchd.conf (thanks @mklement for the tip!)

egrep -v '^\s*#' /etc/launchd.conf | launchctl

You can find out more about launchctl and how it loads launchd.conf with the command man launchctl.


Very nice one! The advantage of using environment.plist though seems to be that OS X honours the contents of that files without the hassle of having to fire up a terminal first. Anyway, I think your answer mainly concentrated on avoiding the necessity of a reboot, so thx for that.
@kapuzineralex Yes it avoids a reboot, also it changes the environment for programs started from Spotlight, which environment.plist does not do.
Setting environment on this way did work for me only till I rebooted. The environment variable did not last after I rebooted the mac. Matthew's answer worked perfectly for me.
@Shamal: I +1'd your comment but bear in mind Matthew's answer requires a reboot, whereas I am pointing out the correct way to change it without a reboot. If you want both, I suggest you put your path settings in launchd.conf (so they persist across reboots), and then use a script with something like this "source /etc/launchctl.conf ; launchctl setenv PATH $PATH", so you can also "refresh" when you don't want to reboot.
@MattCurtis Could you please edit your answer directly to make it clear that while there is no reboot required, the changes will actually be lost after a reboot? Also, the correct way to apply changes in etc/launchd.conf before a reboot would be to use the approach in @MatthewMcCullough's answer: egrep "^setenv\ " /etc/launchd.conf | xargs -t -L 1 launchctl.
P
Peter Mortensen

Up to and including OS X v10.7 (Lion) you can set them in:

~/.MacOSX/environment.plist

See:

https://developer.apple.com/legacy/library/qa/qa1067/_index.html

https://developer.apple.com/library/content/documentation/MacOSX/Conceptual/BPRuntimeConfig/Articles/EnvironmentVars.html

For PATH in the Terminal, you should be able to set in .bash_profile or .profile (you'll probably have to create it though)

For OS X v10.8 (Mountain Lion) and beyond you need to use launchd and launchctl.


This is only if you actually expect them to be used by graphical apps. Since these don't typically use environment variables, it's not a very good place to set them.
There's some very good examples of graphical apps that use environment variables. IntelliJ for example, likes to be able to see M2_HOME to know where Maven lives. To get it to see the variable, you'll need to set it in /etc/launchd.conf instead of environment.plist.
For reference: using preferences.plist was less than ideal with OS X 10.5 since at that time preferences.plist was not read for applications launched through spotlight, see comment by Louis to Matthew's answer and email.esm.psu.edu/pipermail/macosx-emacs/2010-May/002113.html . For OS X 10.6 environment.plist works just like it should.
This is no longer applicable to OSX 10.8 apple.stackexchange.com/questions/57385/…
@tim_yates Could you please edit the first line of your answer to read "Up to and including Lion (10.*7*)", given that that is what's correct? I tried to make that edit to the original, ambiguous "Up to Mountain Lion", and the reviewers botched it.
S
Stepan Vavra

Solution for both command line and GUI applications from a single source (works with Mac OS X v10.10 (Yosemite) and Mac OS X v10.11 (El Capitan))

Let's assume you have environment variable definitions in your ~/.bash_profile like in the following snippet:

export JAVA_HOME="$(/usr/libexec/java_home -v 1.8)"
export GOPATH="$HOME/go"
export PATH="$PATH:/usr/local/opt/go/libexec/bin:$GOPATH/bin"
export PATH="/usr/local/opt/coreutils/libexec/gnubin:$PATH"
export MANPATH="/usr/local/opt/coreutils/libexec/gnuman:$MANPATH"

We need a Launch Agent which will run on each login and anytime on demand which is going to load these variables to the user session. We'll also need a shell script to parse these definitions and build necessary commands to be executed by the agent.

Create a file with plist suffix (e.g. named osx-env-sync.plist) in ~/Library/LaunchAgents/ directory with the following contents:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
  <key>Label</key>
  <string>osx-env-sync</string>
  <key>ProgramArguments</key>
  <array>
    <string>bash</string>
    <string>-l</string>
    <string>-c</string>
    <string>
      $HOME/.osx-env-sync.sh
    </string>
  </array>
  <key>RunAtLoad</key>
  <true/>
</dict>
</plist>

-l parameter is critical here; it's necessary for executing the shell script with a login shell so that ~/.bash_profile is sourced in the first place before this script is executed.

Now, the shell script. Create it at ~/.osx-env-sync.sh with the following contents:

grep export $HOME/.bash_profile | while IFS=' =' read ignoreexport envvar ignorevalue; do
  launchctl setenv "${envvar}" "${!envvar}"
done

Make sure the shell script is executable:

chmod +x ~/.osx-env-sync.sh

Now, load the launch agent for current session:

launchctl load ~/Library/LaunchAgents/osx-env-sync.plist

(Re)Launch a GUI application and verify that it can read the environment variables.

The setup is persistent. It will survive restarts and relogins.

After the initial setup (that you just did), if you want to reflect any changes in your ~/.bash_profile to your whole environment again, rerunning the launchctl load ... command won't perform what you want; instead you'll get a warning like the following:

<$HOME>/Library/LaunchAgents/osx-env-sync.plist: Operation already in progress

In order to reload your environment variables without going through the logout/login process do the following:

launchctl unload ~/Library/LaunchAgents/osx-env-sync.plist
launchctl load ~/Library/LaunchAgents/osx-env-sync.plist

Finally make sure that you relaunch your already running applications (including Terminal.app) to make them aware of the changes.

I've also pushed the code and explanations here to a GitHub project: osx-env-sync.

I hope this is going to be the ultimate solution, at least for the latest versions of OS X (Yosemite & El Capitan).


Works nicely. Slightly worried if this became popular if it would be a security loophole
This solution was the only one I could get to work properly. Great solutions. I can't understand why this should be so hard on mac...
This doesn't work on El Capitan, unfortunately. Your comment from github.com/ersiner/osx-env-sync/issues/1#issuecomment-169803508 explains the problem well.
So, this solution doesn't work, /etc/launchd.conf has no effect, Node.js installs its binary to /usr/local/bin and this path is not in PATH for GUI apps. Therefore, Git hooks using Node don't work in GUI Git apps like SourceTree at all in El Capitan. This is terrible.
The problem is only about the PATH variable. I hope we can find a solution soon.
P
Peter Mortensen

Do: vim ~/.bash_profile The file may not exist (if not, you can just create it). Type in this and save the file: export PATH=$PATH:YOUR_PATH_HERE Run source ~/.bash_profile


+1 export is what I was going to suggest, since BASH doesn't support setenv
Works for now. This whole thing looks a lot more complicated than I thought. Will have to dedicate some more time for all these later. Thanks.
d
dcow

There are essentially two problems to solve when dealing with environment variables in OS X. The first is when invoking programs from Spotlight (the magnifying glass icon on the right side of the Mac menu/status bar) and the second when invoking programs from the Dock. Invoking programs from a Terminal application/utility is trivial because it reads the environment from the standard shell locations (~/.profile, ~/.bash_profile, ~/.bashrc, etc.)

When invoking programs from the Dock, use ~/.MacOSX/environment.plist where the <dict> element contains a sequence of <key>KEY</key><string>theValue</string> elements.

When invoking programs from Spotlight, ensure that launchd has been setup with all the key/value settings you require.

To solve both problems simultaneously, I use a login item (set via the System Preferences tool) on my User account. The login item is a bash script that invokes an Emacs lisp function although one can of course use their favorite scripting tool to accomplish the same thing. This approach has the added benefit that it works at any time and does not require a reboot, i.e. one can edit ~/.profile, run the login item in some shell and have the changes visible for newly invoked programs, from either the Dock or Spotlight.

Details:

Login item: ~/bin/macosx-startup

#!/bin/bash
bash -l -c "/Applications/Emacs.app/Contents/MacOS/Emacs --batch -l ~/lib/emacs/elisp/macosx/environment-support.el -f generate-environment"

Emacs lisp function: ~/lib/emacs/elisp/macosx/envionment-support.el

;;; Provide support for the environment on Mac OS X

(defun generate-environment ()
  "Dump the current environment into the ~/.MacOSX/environment.plist file."
  ;; The system environment is found in the global variable:
  ;; 'initial-environment' as a list of "KEY=VALUE" pairs.
  (let ((list initial-environment)
        pair start command key value)
    ;; clear out the current environment settings
    (find-file "~/.MacOSX/environment.plist")
    (goto-char (point-min))
    (setq start (search-forward "<dict>\n"))
    (search-forward "</dict>")
    (beginning-of-line)
    (delete-region start (point))
    (while list
      (setq pair (split-string (car list) "=")
            list (cdr list))
      (setq key (nth 0 pair)
            value (nth 1 pair))
      (insert "  <key>" key "</key>\n")
      (insert "  <string>" value "</string>\n")

      ;; Enable this variable in launchd
      (setq command (format "launchctl setenv %s \"%s\"" key value))
      (shell-command command))
    ;; Save the buffer.
    (save-buffer)))

NOTE: This solution is an amalgam of those coming before I added mine, particularly that offered by Matt Curtis, but I have deliberately tried to keep my ~/.bash_profile content platform independent and put the setting of the launchd environment (a Mac only facility) into a separate script.


Wow. I'm not saying this won't work, but ... I'm just appalled at the complexity required to get a consistent environment on OS X.
This works the best out of all the solutions I've seen for 10.9. The only flaw is that, since login items run in an indeterminate order, if Emacs (for example) is launched at login (because it was open at logout, for example), it won't necessarily have the environment variables unless you restart it, because it's launched before your script is.
P
Peter Mortensen

Another, free, opensource, Mac OS X v10.8 (Mountain Lion) Preference pane/environment.plist solution is EnvPane.

EnvPane's source code available on GitHub. EnvPane looks like it has comparable features to RCEnvironment, however, it seems it can update its stored variables instantly, i.e. without the need for a restart or login, which is welcome.

As stated by the developer:

EnvPane is a preference pane for Mac OS X 10.8 (Mountain Lion) that lets you set environment variables for all programs in both graphical and terminal sessions. Not only does it restore support for ~/.MacOSX/environment.plist in Mountain Lion, it also publishes your changes to the environment immediately, without the need to log out and back in. EnvPane includes (and automatically installs) a launchd agent that runs 1) early after login and 2) whenever the ~/.MacOSX/environment.plist changes. The agent reads ~/.MacOSX/environment.plist and exports the environment variables from that file to the current user's launchd instance via the same API that is used by launchctl setenv and launchctl unsetenv.

Disclaimer: I am in no way related to the developer or his/her project.

P.S. I like the name (sounds like 'Ends Pain').


EnvPane can't set PATH at the moment. For more details see my bug report: github.com/hschmidt/EnvPane/issues/5
I ♥️ this thing.. Only drawback.. which I think ANY solution will be a victim of.. is - having to restart a process - to inherit the new "environment". Wonk wonk.
@sorin: Can you open an issue on the GitHub site with a description of the problem you are experiencing? EnvPane works for me on 10.10. Disclaimer: I am the author of EnvPane.
P
Peter Mortensen

On Mountain Lion all the /etc/paths and /etc/launchd.conf editing doesn't make any effect!

Apple's Developer Forums say:

"Change the Info.plist of the .app itself to contain an "LSEnvironment" dictionary with the environment variables you want. ~/.MacOSX/environment.plist is no longer supported."

So I directly edited the application's Info.plist (right click on "AppName.app" (in this case SourceTree) and then "Show package contents").

https://i.stack.imgur.com/Z6ZHP.png

And I added a new key/dict pair called:

<key>LSEnvironment</key>
<dict>
     <key>PATH</key>
     <string>/Users/flori/.rvm/gems/ruby-1.9.3-p362/bin:/Users/flori/.rvm/gems/ruby-1.9.3-p362@global/bin:/Users/flori/.rvm/rubies/ruby-1.9.3-p326/bin:/Users/flori/.rvm/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:</string>
</dict>

(see: LaunchServicesKeys Documentation at Apple)

https://i.stack.imgur.com/oiwcE.png

Now the application (in my case Sourcetree) uses the given path and works with Git 1.9.3 :-)

PS: Of course you have to adjust the Path entry to your specific path needs.


This solution meets the standard of least intrusive on the system. Thanks.
@John Vance +1 Totally agree, system-wide changes are always risky as Jason T. Miller explains clearly in his answer
It has no effect for me in El Capitan. :(
On High Sierra 10.13, if I modify application's Info.plist file then the application fails to load: LSOpenURLsWithRole() failed with error -10810 for the file /Applications/Slack.app.
M
Max Leske

Update (2017-08-04)

As of (at least) macOS 10.12.6 (Sierra) this method seems to have stopped working for Apache httpd (for both the system and the user option of launchctl config). Other programs do not seem to be affected. It is conceivable that this is a bug in httpd.

Original answer

This concerns OS X 10.10+ (10.11+ specifically due to rootless mode where /usr/bin is no longer writeable).

I've read in multiple places that using launchctl setenv PATH <new path> to set the PATH variable does not work due to a bug in OS X (which seems true from personal experience). I found that there's another way the PATH can be set for applications not launched from the shell:

sudo launchctl config user path <new path>

This option is documented in the launchctl man page:

config system | user parameter value Sets persistent configuration information for launchd(8) domains. Only the system domain and user domains may be configured. The location of the persistent storage is an implementation detail, and changes to that storage should only be made through this subcommand. A reboot is required for changes made through this subcommand to take effect. [...] path Sets the PATH environment variable for all services within the target domain to the string value. The string value should conform to the format outlined for the PATH environment variable in environ(7). Note that if a service specifies its own PATH, the service-specific environment variable will take precedence. NOTE: This facility cannot be used to set general environment variables for all services within the domain. It is intentionally scoped to the PATH environment vari- able and nothing else for security reasons.

I have confirmed this to work with a GUI application started from Finder (which uses getenv to get PATH). Note that you only have to do this once and the change will be persistent through reboots.


It works for me, too. sudo launchctl procinfo <gui-pid> shows newly set PATH environment. But sudo launchctl config user path <new path> actually set for all users... (confirmed by adding new user & using Sublime Text's python console)
This doesn't seem to have an effect on the PATH environment variable of applications that are reopened at login (that were open when shutting down).
Interesting. That would mean that for applications that will be reopened the environment (or a subset thereof) is being saved.
@MaxLeske No, the reopened applications are being started before the environment variable is changed. So, it's not just the first time after doing sudo launchctl config user path, that this happens (which you seem to be assuming?).
@ShlomiSchwartz launchctl does not allow you to set arbitrary environment variables. The PATH variable is an exception.
J
Jason T. Miller

While the answers here aren't "wrong", I'll add another: never make environment variable changes in OS X that affect "all processes", or even, outside the shell, for all processes run interactively by a given user.

In my experience, global changes to environment variables like PATH for all processes are even more likely to break things on OS X than on Windows. Reason being, lots of OS X applications and other software (including, perhaps especially, components of the OS itself) rely on UNIX command-line tools under the hood, and assume the behavior of the versions of these tools provided with the system, and don't necessarily use absolute paths when doing so (similar comments apply to dynamically-loaded libraries and DYLD_* environment variables). Consider, for instance, that the highest-rated answers to various Stack Overflow questions about replacing OS X-supplied versions of interpreters like Python and Ruby generally say "don't do this."

OS X is really no different than other UNIX-like operating systems (e.g., Linux, FreeBSD, and Solaris) in this respect; the most likely reason Apple doesn't provide an easy way to do this is because it breaks things. To the extent Windows isn't as prone to these problems, it's due to two things: (1) Windows software doesn't tend to rely on command-line tools to the extent that UNIX software does, and (2) Microsoft has had such an extensive history of both "DLL hell" and security problems caused by changes that affect all processes that they've changed the behavior of dynamic loading in newer Windows versions to limit the impact of "global" configuration options like PATH.

"Lame" or not, you'll have a far more stable system if you restrict such changes to smaller scopes.


Telling people not to do the thing they asked how to do is not an answer to the question they asked. Preventing people from doing this is also breaking things. Apple's modus operandi.
Setting the PATH in /Applications/App.app/Contents/Info.plist with the LSEnvironment key developer.apple.com/library/archive/documentation/General/… might be the current recommended solution.
@DaveX No, it definitely isn’t. You mustn’t modify the contents of an app bundle. Doing so can cause the app to fail to launch (even if the configuration is correct!) because the contents no longer match the code signature.
P
Peter Mortensen

Sometimes all of the previous answers simply don't work. If you want to have access to a system variable (like M2_HOME) in Eclipse or in IntelliJ IDEA the only thing that works for me in this case is:

First (step 1) edit /etc/launchd.conf to contain a line like this: "setenv VAR value" and then (step 2) reboot.

Simply modifying .bash_profile won't work because in OS X the applications are not started as in other Unix'es; they don't inherit the parent's shell variables. All the other modifications won't work for a reason that is unknown to me. Maybe someone else can clarify about this.


Applications started from Spotlight or by any other means all have /etc/launchd.conf read by their parent process, thus making that an appealing choice for where to set environment variables visible in all apps and shells.
See my answer for another solution, which avoids a reboot - stackoverflow.com/questions/135688/…
My MaxOS 10.6 machine does not have the /etc/launchd.conf file present. Is this either a new or an obsolete thing as of this version ? Or is this machine messed up ?
R
Russell B

After chasing the Environment Variables preference pane and discovering that the link is broken and a search on Apple's site seems to indicate they've forgotten about it... I started back onto the trail of the elusive launchd process.

On my system (Mac OS X 10.6.8) it appears that variables defined in environment.plist are being reliably exported to apps launched from Spotlight (via launchd). My trouble is that those vars are not being exported to new bash sessions in Terminal. I.e. I have the opposite problem as portrayed here.

NOTE: environment.plist looks like JSON, not XML, as described previously

I was able to get Spotlight apps to see the vars by editing ~/MacOSX/environment.plist and I was able to force the same vars into a new Terminal session by adding the following to my .profile file:

eval $(launchctl export)

Not that elusive: RCenvironment
Nice tip about launchctl export. But I wouldn't put that as-is into .profile. It will overwrite your $PATH with one that doesn't include /usr/local/bin. But you can use a regex to select the vars you are interested in: ``eval $(launchctl export | grep '^my.*=').
On my new Mountain Lion machine (10.8.2) the environment.plist is completely worthless. See Matthew's answer for the right track. It's all about launched and the launchctl command-line app along with /etc/launchd.conf. You can read up yourself with man launchd, man launchctl, and man launchd.conf in a terminal window. Glad Apple keeps the man pages up to date, even if the Mac Developer Library lags a bit.
J
John Millikin

Any of the Bash startup files -- ~/.bashrc, ~/.bash_profile, ~/.profile. There's also some sort of weird file named ~/.MacOSX/environment.plist for environment variables in GUI applications.


P
Peter Mortensen

Here is a very simple way to do what you want. In my case, it was getting Gradle to work (for Android Studio).

Open up Terminal.

Run the following command: sudo nano /etc/paths or sudo vim /etc/paths

Enter your password, when prompted.

Go to the bottom of the file, and enter the path you wish to add.

Hit Control + X to quit.

Enter 'Y' to save the modified buffer.

Open a new terminal window then type: echo $PATH

You should see the new path appended to the end of the PATH.

I got these details from this post:

Add to the PATH on Mac OS X 10.8 Mountain Lion and up


c
courtlandj

Much like the answer Matt Curtis gave, I set environment variables via launchctl, but I wrap it in a function called export, so that whenever I export a variable like normal in my .bash_profile, it is also set by launchctl. Here is what I do:

My .bash_profile consists solely of one line, (This is just personal preference.) source .bashrc My .bashrc has this: function export() { builtin export "$@" if [[ ${#@} -eq 1 && "${@//[^=]/}" ]] then launchctl setenv "${@%%=*}" "${@#*=}" elif [[ ! "${@//[^ ]/}" ]] then launchctl setenv "${@}" "${!@}" fi } export -f export The above will overload the Bash builtin "export" and will export everything normally (you'll notice I export "export" with it!), then properly set them for OS X app environments via launchctl, whether you use any of the following: export LC_CTYPE=en_US.UTF-8 # ~$ launchctl getenv LC_CTYPE # en_US.UTF-8 PATH="/usr/local/bin:${PATH}" PATH="/usr/local/opt/coreutils/libexec/gnubin:${PATH}" export PATH # ~$ launchctl getenv PATH # /usr/local/opt/coreutils/libexec/gnubin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin export CXX_FLAGS="-mmacosx-version-min=10.9" # ~$ launchctl getenv CXX_FLAGS # -mmacosx-version-min=10.9 This way I don't have to send every variable to launchctl every time, and I can just have my .bash_profile / .bashrc set up the way I want. Open a terminal window, check out your environment variables you're interested in with launchctl getenv myVar, change something in your .bash_profile/.bashrc, close the terminal window and re-open it, check the variable again with launchctl, and voilá, it's changed. Again, like the other solutions for the post-Mountain Lion world, for any new environment variables to be available for apps, you need to launch or re-launch them after the change.


Useful answer - thanks. I just updated it because your original solution didn't handle cases where the value of the environment variable you were setting had equals signs in it (e.g., CXX_FLAGS="-mmacosx-version-min=10.9"
@SteveBroberg - just a one character change fixes up the Bash regexp without needing sed! (Don't get me wrong, I love sed, but this works and is a lot shorter.)
I figured there had to be a better way, but I'm not a bash guru, and I couldn't google what %%, ## were, etc.
P
Peter Mortensen

I think the OP is looking for a simple, Windows-like solution.

Here you go:

http://www.apple.com/downloads/macosx/system_disk_utilities/environmentvariablepreferencepane.html


Still available at RCenvironment
C
Claudio Floreani

To be concise and clear about what each file is intended for

~/.profile is sourced every time Terminal.app is launched

~/.bashrc is where "traditionally" all the export statements for Bash environment are set

/etc/paths is the main file in Mac OS that contains the list of default paths for building the PATH environment variable for all users

/etc/paths.d/ contains files that hold additional search paths

Non-terminal programs don't inherit the system wide PATH and MANPATH variables that your terminal does! To set environment for all processes launched by a specific user, thus making environment variables available to Mac OS X GUI applications, those variables must be defined in your ~/.MacOSX/environment.plist (Apple Technical Q&A QA1067)

Use the following command line to synchronize your environment.plist with /etc/paths:

defaults write $HOME/.MacOSX/environment PATH "$(tr '\n' ':' </etc/paths)"

/etc/paths.d/ was the method I was looking for, as I was trying to understand why every process I started had a particular directory of an installed component in the PATH environment on my machine, but it wasn't working correctly on another. Turns out it was in a file under /etc/paths.d, which /usr/libexec/path_helper uses to construct the PATH environment variable when starting new processes.
P
Peter Mortensen

/etc/launchd.conf is not used in OS X v10.10 (Yosemite), OS X v10.11 (El Capitan), macOS v10.12 (Sierra), or macOS v10.13 (High Sierra).

From the launchctl man page:

/etc/launchd.conf file is no longer consulted for subcommands to run during early boot time;
this functionality was removed for security considerations.

The method described in this Ask Different answer works for me (after a reboot): applications launched from the Dock or from Spotlight inherit environment variables that I set in ~/Library/LaunchAgents/my.startup.plist. (In my case, I needed to set LANG, to en_US.UTF-8, for a Sublime Text plugin.)


On reboot is there a load order that ensures my.startup.plist would have been loaded before applications from last session are restarted?
P
Peter Mortensen

The $PATH variable is also subject to path_helper, which in turn makes use of the /etc/paths file and files in /etc/paths.d.

A more thorough description can be found in PATH and other environment issues in Leopard (2008-11)


C
CodeOverRide

Just did this really easy and quick. First create a ~/.bash_profile from terminal:

touch .bash_profile

then

open -a TextEdit.app .bash_profile

add

export TOMCAT_HOME=/Library/Tomcat/Home

save documement and you are done.


Perfecto. I followed steps for JAVA_HOME, Just added export JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_201.jdk/Contents/Home and real quick success!
Great @NarendraC!
P
Peter Mortensen

All the magic on iOS only goes with using source with the file, where you export your environment variables.

For example:

You can create an file like this:

export bim=fooo
export bom=bar

Save this file as bimbom.env, and do source ./bimbom.ev. Voilá, you got your environment variables.

Check them with:

echo $bim

F
Fernando Martínez

It's simple:

Edit ~/.profile and put your variables as follow

$ vim ~/.profile

In file put:

MY_ENV_VAR=value

Save ( :wq ) Restart the terminal (Quit and open it again) Make sure that`s all be fine:

$ echo $MY_ENV_VAR $ value


P
Peter Mortensen

For a single user modification, use ~/.profile of the ones you listed. The following link explains when the different files are read by Bash.

http://telin.ugent.be/~slippens/drupal/bashrc_and_others

If you want to set the environment variable for gui applications you need the ~/.MacOSX/environment.plist file


P
Peter Mortensen

Well, I'm unsure about the /etc/paths and ~/.MacOSX/environment.plist files. Those are new.

But with Bash, you should know that .bashrc is executed with every new shell invocation and .bash_profile is only executed once at startup.

I don't know how often this is with Mac OS X. I think the distinction has broken down with the window system launching everything.

Personally, I eliminate the confusion by creating a .bashrc file with everything I need and then do:

ln -s .bashrc .bash_profile

M
MiB

One thing to note in addition to the approaches suggested is that, in OS X 10.5 (Leopard) at least, the variables set in launchd.conf will be merged with the settings made in .profile. I suppose this is likely to be valid for the settings in ~/.MacOSX/environment.plist too, but I haven't verified.


P
Peter Mortensen

Set up your PATH environment variable on Mac OS

Open the Terminal program (this is in your Applications/Utilities folder by default). Run the following command

touch ~/.bash_profile; open ~/.bash_profile

This will open the file in the your default text editor.

For Android SDK as example:

You need to add the path to your Android SDK platform-tools and tools directory. In my example I will use "/Development/android-sdk-macosx" as the directory the SDK is installed in. Add the following line:

export PATH=${PATH}:/Development/android-sdk-macosx/platform-tools:/Development/android-sdk-macosx/tools

Save the file and quit the text editor. Execute your .bash_profile to update your PATH:

source ~/.bash_profile

Now every time you open the Terminal program your PATH will include the Android SDK.


P
Peter Mortensen

It's quite simple. Edit file .profile (vi, nano, Sublime Text or other text editor) file. You can found it at the ~/ directory (user directory) and set like this:

export MY_VAR=[your value here]

Example with Java home:

export JAVA_HOME=/Library/Java/JavaVirtualMachines/current

Save it and return to the terminal.

You can reload it with:

source .profile

Or close and open your terminal window.


B
Ben Carp

Feb 2022 (MacOs 12+)

Solutions here should work after reboot or application restart.

CLI

Open your CLI of choice config file.

For bash open ~/.bash_profile

For zsh open ~/.zshrc

add (or replace)

export varName=varValue 

(if varValue has spaces in it - wrap it in ")

Make sure to restart command line app.

GUI

Complete the CLI step. Make sure GUI app is closed. Open GUI app from the command line. For example:

open /Applications/Sourcetree.app

(you can also alias this command in the .zshrc)

Principles

Mac does not have a configuration options that sets environment variable for all contexts.

Avoid changing anything outside your user profile.

Doesn't work anymore

launchctl config user varName varVal (MacOS 12.1+)

Editing /etc/launchd.conf

xml file with plist suffix


Is it possible to set environment variables for a specific launchd service?
P
Peter Mortensen

There are two type of shells at play here.

Non-login: .bashrc is reloaded every time you start a new copy of Bash

Login: The .profile is loaded only when you either login, or explicitly tell Bash to load it and use it as a login shell.

It's important to understand here that with Bash, file .bashrc is only read by a shell that's both interactive and non-login, and you will find that people often load .bashrc in .bash_profile to overcome this limitation.

Now that you have the basic understanding, let’s move on to how I would advice you to set it up.

.profile: create it non-existing. Put your PATH setup in there.

.bashrc: create if non-existing. Put all your aliases and custom methods in there.

.bash_profile: create if non-existing. Put the following in there.

.bash_file:

#!/bin/bash
source ~/.profile # Get the PATH settings
source ~/.bashrc  # Get Aliases and Functions
#

P
Peter Mortensen

Login Shells

/etc/profile

The shell first executes the commands in file /etc/profile. A user working with root privileges can set up this file to establish systemwide default characteristics for users running Bash.

.bash_profile
.bash_login
.profile

Next the shell looks for ~/.bash_profile, ~/.bash_login, and ~/.profile (~/ is short- hand for your home directory), in that order, executing the commands in the first of these files it finds. You can put commands in one of these files to override the defaults set in /etc/profile. A shell running on a virtual terminal does not execute commands in these files.

.bash_logout

When you log out, bash executes commands in the ~/.bash_logout file. This file often holds commands that clean up after a session, such as those that remove temporary files.

Interactive Nonlogin Shells

/etc/bashrc

Although not called by bash directly, many ~/.bashrc files call /etc/bashrc. This setup allows a user working with root privileges to establish systemwide default characteristics for nonlogin bash shells.

.bashrc

An interactive nonlogin shell executes commands in the ~/.bashrc file. Typically a startup file for a login shell, such as .bash_profile, runs this file, so both login and nonlogin shells run the commands in .bashrc.

Because commands in .bashrc may be executed many times, and because subshells inherit exported variables, it is a good idea to put commands that add to existing variables in the .bash_profile file.